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About this Document
This document explains Helmsman 4.0 features with the intent of improving
and shortening the startup time for users. Topics include:

• Installation and startup

• Helmsman preferences

• Working with collections

• Searching for documents

• Opening and viewing documents

• Printing
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Chapter 1  Introduction
Helmsman 4.0 is a Client/Server and CD-ROM based document browsing
system.  The purpose of Helmsman is to provide electronic documentation to
Nortel and its customers.

These electronic documents include technical manuals, design specifications
and schematics, and other information needed by product users to perform
daily tasks.  These electronic documents are organized into groups of related
documents called collections.

Helmsman 4.0 relies on a number of compact disks, remote servers, and local
servers to electronically store and retrieve the information found in these
document collections.

1.1  Product Highlights
• View document title and number for all documents in a set of collections

• Search documents using criteria found in the document title, number, or
text;  or based on product, type, or function categories

• View documents in Adobe Acrobat Exchange

• Display search occurrences within documents and view the pages where
those words occur

• Use Adobe Portable Document Format (PDF) for document viewing

• Look up words using the Word List and copy and paste into the Search
Editor

• Use the Online Help System

1.2  Product Navigation
• Navigate through Helmsman using the menus, toolbar, and buttons

provided in the browser window

• Open as many as ten PDF documents simultaneously

• Open document collections and individual documents using the Search
Editor or Search Occurrences dialog box

• Use the Adobe Acrobat Exchange feature set for navigating documents
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1.2.1 Menus
The browser window contains five menus to make searching and viewing
documents easier.

Menu Command

File Open Collection

Print Document List

Properties

Quit

Menu Command

View Toolbar

Status Bar

Message of the Day

Set Categories

Word List

Search Occurrences

Preferences

Menu Command

Navigate Next Document

Previous Document

Menu Command

Windows Tidy Windows

Hide Helmsman

Hide Others

Show All

Helmsman

Menu Command

Help About Help
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Chapter 2  Getting Started
This chapter describes the installation and setup of Helmsman 4.0.  Refer to
the readme.txt for the most recent installation instructions.

2.1  Platforms and System Requirements
This Helmsman product runs on the following Macintosh platforms.

Macintosh Requirements
Platforms Power PC 7.6.1or later

Disk Space Installation
Root Directory

35 MB

RAM 32 MB recommended

Adobe Acrobat Exchange Version 3.01

2.2  Acrobat Exchange
The Helmsman products provide a medium to display electronic documentation.
This documentation is stored within a database containing specific collections of
documents.  The 4.0 generation of Helmsman technology utilizes third-party
tools, such as Acrobat Exchange, which help Helmsman perform its functions
more efficiently.

2.3  Installation
Helmsman is distributed on a CD-ROM.

1. Close all open applications and start the Helmsman Installer.

2. If you do not have Acrobat Exchange 3.01 or greater:

• The Helmsman Installer will copy an Acrobat Exchange Installer
folder at the top level of your startup disk.  When you quit the
Helmsman Installer the Acrobat Exchange Installer will automatically
begin.  Follow the instructions.  When finished, you will be asked to
restart your Macintosh.

• After you have re-booted your Macintosh, run the Helmsman Installer
again and it will finish the installation.

• If you wish, you may delete the Acrobat Exchange Installer folder.  It
is no longer needed.
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3. If you already have Acrobat Exchange 3.01 or greater follow the
Helmsman Installer instructions.  When you are finished, you will be ready
to begin using the Helmsman application by double clicking it.

4. The first time you start up Helmsman, it will create a Helmsman Prefs
folder in your System Preferences folder.  Setting or changing the data
source is accomplished from the General tab of the Helmsman Preferences
dialog box.  If working with a server, select the Network Server option,
and type in the IP address and port number of the server.  (If you do not
have this information, contact your system administrator).  If using a local
data source, select the Local option and type the complete path to the
local collections or click Browse to select the path.  The local collection
on the CD is the first COLLECT: directory on the CD.

5. The Helmsman Installer will automatically copy an Acrobat plug-in called
HelmXHL into the Acrobat Plug-ins folder.  An extra copy of the
HelmXHL plug-in will be placed in your Helmsman folder if needed.  This
plug-in is used for highlighting search words in Acrobat Exchange.

6. The Verity folder should remain in your Helmsman folder.  The program
will not work without it.

7. The Helmsman Guide should also remain in your Helmsman folder at the
same level as the Helmsman application.  Helmsman will work without it,
but you won’t be able to access the Apple Guide Help System.

8. The installer will check to see if you have Apple’s Open Transport
installed.  If it does not find Open Transport, it will provide a warning
message indicating you should install it.  An installation program for Open
Transport should be on your Helmsman CD.  You should also be able to
install it from your system software.

9. The Installer Log File is a time-stamped text file detailing what the
Helmsman installer did.

10. Finally, there are the license.txt and ReadMe.txt files, which are self-
explanatory.

2.4  Getting Started
The Open Collection dialog box displays when you start using Helmsman.
At least one collection must be selected.  After selecting a collection and
clicking Open, the browser window displays the list of documents from the
selected collection.
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2.5  Technical Support
If a problem is encountered which is not covered in the Help system or the
Users Guide, call Helmsman technical support.

• In North America call 1-888-HELMSMAN Monday through Friday 9-5
CST.

• In the United Kingdom call 0-800-966-831.

• In all other countries call 1-615-432-4848.

• E-mail is: helmsman.support@nortelnetworks.com
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Chapter 3  Helmsman Preferences
Helmsman Preferences allow customization of the program.  The first time
Helmsman is run, the program opens to the Helmsman Preferences dialog
box.  These settings should be specified at this time. The tabs on the
Helmsman Preferences dialog box are General, Search, and Document
Viewer.

The most important thing about setting Helmsman Preferences is that two
pieces of information are required:

• Setting the data source

• Setting the document viewing method

3.1  General Preferences
The General tab of the Helmsman Preferences dialog box is used to set up
data sources to open document collections.  Use this tab to alternate between
local and network server data sources as needed.

If the data source is a Network Server, type the Server IP Address and
Server Port, and select the Timeout After.  If using a Local data source,
type the path to the collection or click Browse to select the path.

The Language default is English.  This cannot be changed.

Note:  If using Helmsman with a network, obtain the server IP address, the
server port, and the correct user name and password from the system
administrator prior to proceeding.

3.1.1  Network Server Data Source
The following options are available for you to set up a network server data
source.

• The Server IP Address is a unique identifier for the different computers
on a network.

• The Server Port defines the route to the server being accessed.

• The Timeout After instructs Helmsman to place a qualifier on the server
for retrieving data.  Select the amount of time allowed before the server
“times out.”  The range is 30 seconds to 5 minutes.  The default is 30
seconds.
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3.1.2  Local Data Source
If using Helmsman with a local data source such as a CD-ROM:

1. Select the Local check box.

2. Type the complete path to the local collections or click Browse to select
the path.

3. When finished setting preferences, click OK to save the preferences and
close the dialog box.

3.2  Search Preferences
Use the Search tab in the Preferences dialog box to set up search
preferences.

1. Multiple search words help narrow searches by limiting the range between
multiple terms in the Search Editor.  This is especially useful for those
searches involving a phrase or group of words that is repeated throughout a
document.  Choices for multiple word searches are:  in same document,
paragraph, sentence, or phrase. The default is in same document.

2. The Distance between words for “Is Near” searches helps narrow a
search based on words or phrases that are near or surrounding the text or
information being searched.  The range can be from 1 to 999 words.  The
default is set to 8.  This option is only available with In Text searches.

3. When finished setting preferences, click OK to save the preferences and
close the dialog box.

3.3  Document Viewer Preferences
The Document Viewer preferences are used to control various
characteristics of how documents are rendered once they are opened.  These
characteristics include the location of the viewer application (Acrobat
Exchange), the size of the viewer window, and a field to specify the location
in the document where it will be opened.

3.3.1  Viewing Documents
Helmsman uses Adobe Acrobat Exchange to view documents.  Exchange is a
fully functional independent program that maintains its own user interface
that is separate from Helmsman.

For a brief description of the Adobe Acrobat Exchange features, see Adobe
Acrobat Exchange Help.
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Type the path or click Browse to select the path of the Adobe Acrobat
Exchange program.

3.3.2  Open Documents To
Open documents to allows you to select the first page displayed when a
document is opened.

1. The default is First page with search occurrence.  If set to First page
with search occurrence, the document opens to the first occurrence of
the search term.

2. The other option is First page.  If set to First page, the document opens
to the first page.

3. When finished setting preferences, click OK to save the preferences and
close the dialog box.
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Chapter 4  Opening Collections
This chapter explains different options for opening collections.

4.1  Opening Collections
After you set up the Helmsman Preferences, the Open Collections dialog
box appears.  If you are using a local data source, the collection list that
displays will be those on the CD-ROM.  If you are using a network data
source, the collections listed are those for which you have privileges through
your user name and password.  If you have problems, contact your system
administrator.

To open a different collection:
1. Select Open Collection from the File menu, or click the Open

Collection button on the toolbar.

2. When the Open Collections dialog appears in front of the browser
window, select one or more collections and click Open.

3. After selecting a collection, the Open Collection dialog box closes and
the browser window displays the document list.

Note:  If you change a CD-ROM while viewing documents, you must
choose Open Collections to view the new documents.

4.2  Message of the Day
If using a network server data source, the Message of the Day dialog box
displays messages regarding that server.  Each message is identified by the
server from which it originated.  This message appears on the Open Collection
dialog box or can be accessed from the View menu.  There is no Message of
the Day for local data sources.

4.3  Helmsman Browser
Once you have opened a collection all documents in that collection display in
the Helmsman browser.  The main window of the Helmsman program is the
browser.  After successfully starting Helmsman, all other tasks can be
accomplished from this window.  The browser window displays the document
list.  Only 250 documents will display in the browser if one or more
collections contain more than 250 documents.  Click Next 250 to display the
next 250 documents of the selected collection in the document list. Click
Previous 250 to list the previous 250 documents.

The Search Editor is located in the lower portion of the browser window
and is discussed in Chapter 6, “Searching.”  With this editor and the powerful
tools associated with it, searching can be accomplished quickly.
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Chapter 5  Retrieving and Viewing
Documents

Retrieving and viewing documents is possible through the use of Adobe
Acrobat Exchange.  Select any document in the browser and click Open to
view the document.  As many as ten documents can be opened
simultaneously.

Note:  You will receive an error upon opening the eleventh document.

5.1  Viewing a Document
To view a document there must be at least one collection open.  Click the
Open Collections button, or access the Open Collections command from
the File menu.

After opening a collection, you can search through these documents as
discussed in Chapter 6, “Searching.”

To Open a Document
1) Select a document in the browser window.

2) Click Open.

3) An Adobe Acrobat Exchange window opens in which the document
appears.

4) Use the Adobe Acrobat Exchange features to navigate within the
document.

Adobe Acrobat features are explained in the Adobe Acrobat Help system.
Refer to the Help menu, and related documents installed in the Acrobat
directory.

5.2  Next and Previous Document
Use the Next Document and Previous Document buttons on the toolbar to
view the next or previous document in the document list.

5.3  Printing a Document
Use Adobe Acrobat Exchange to print selected pages or the entire document.
Select the Print command from the File menu.

5.4  Document Properties
Document Information is available on the Document Properties dialog box.
From the File menu, click the Properties command and the Document
Properties dialog box appears.
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All pertinent information about the selected document is listed for reference
including the title, document number, revision number, number of pages in the
document, file name, collection the document resides in, server (if applicable),
and document categories.

Click OK to exit the dialog box and return to the browser window.
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Chapter 6  Searching

6.1  Overview
The Search Editor helps you build queries that find documents quickly.  It is
located in the lower portion of the browser window.  Search results also
appear in the browser window.

The Search Editor has four search areas or text boxes where search terms
are typed.  The Search Editor is not case-sensitive.  If a word is typed in
upper case – occurrences that are all upper case, lower case, and sentence
case (only the first letter is capitalized) are found.

Search terms can be located In Text (in the document text), In Title (in the
document title), and In Number (in the document number).  Multiple search
words appearing in a single search text box must be in the same order in the
document for it to be found.

Use the Search Editor to type search terms that are combined to form a
query.  The default conjunction connecting these search terms is And.  A
document will not match unless both search terms are found in the location
specified.  The default location is In Text.

Example:  If the first search term is “line” and the second search term is
“trunk,” the And conjunction will find documents where both “line” and
“trunk” are found.

The Or conjunction will match a particular document if either the first search
term or the second search term are found (or both).  In the previous example,
if “line” and “trunk” are the search terms and the conjunction is Or, the
search will find documents that contain either term.

The last conjunction available is Is Near.  This conjunction works only with
In Text searches.  Documents are found only if the first search term is found
within a certain number of words of the second search term.  Is Near
parameters are set up in the Search tab of the Helmsman Preferences dialog
box.

6.2  Set Categories
Set Categories is accessed by clicking the Set Categories button in the
Search Editor, or by selecting the Set Categories command from the View
menu.
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Note:  This feature is not available until one or more collections are
opened.  This feature is not available for collections or group of
collections that contain over 2000 documents.

Setting Categories:
1. In the Category box, select a category:

Product:  what the document describes

Function:  what kind of document it is

Type:  what the product does

2. If the document has previously-defined categories, these appear in the list
on the left.

3. To set a category, select a category and click Add.

4. The category appears in the list on the right.

5. Repeat this process for every category value that is desired.

6. To remove a category, select it from the list on the right, then click
Remove.  To remove all the selections, click Remove All.

7. After the values have been selected for each category, click OK.

8. The Set Categories function is effective immediately.  Helmsman limits
current and future searches to the chosen categories.

9. You can add and remove by double-clicking on the desired element in the
appropriate list.

Note:  Set categories are effective until changed, or until Helmsman is
restarted.  Set categories selections are not saved from session to
session, so be sure to access this dialog box at the beginning of each
session in Helmsman.

If experiencing difficulty, it may mean that categories should be reviewed.
Review the choices based upon their descriptions above, change categories if
necessary, and proceed with the search.

This procedure can be repeated several times until all the categories and
subcategories needed are included in the right-hand list.  In the same manner,
other categories can be selected, added, or removed.
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6.3 Word List
Use the Word List feature to look up a single word, part of a word, or
multiple words.  The results of a Word List lookup can be copied and pasted
into the Search Editor in the browser window.

1. Select the Word List command from the View menu.

2. Type the word or partial word in the text box.

3. Click Lookup.

4. The number of occurrences and the chosen word as well as variations are
listed.  The Word List does not specify in which documents the word is
found, only the number of occurrences.

Note:  The Word List feature is not case sensitive.  Word List will find all
occurrences of that word or fragment.

Example
A lookup on the word “switch” found “switch,” “SWITCH,”
“SWITCHABLE,” “Switching.”

6.3.1  Word List with Copy and Paste
The Copy button allows one or more words to be copied from the Word List
box into the Search Editor in the browser window.

To copy a word, select it, then click Copy.  The word selected will be copied
to the first empty text box in the Search Editor.  To copy additional words
into the remaining empty text boxes in the Search Editor, simply select
another word and click Copy.

6.4  Searching for Documents
Use Word List, Set Categories, or the Search Editor to narrow your
search.  Use Search Occurrences to view the number of occurrences of the
search terms and the pages on which they appear.

Open the selected document to view its contents.  To view other documents
in the list, click the Next Document or Previous Document buttons on the
toolbar.

6.4.1   Asterisk Searches
An asterisk serves as a wildcard character representing one or more
characters.

In Text Example
Search = mo* (Find all documents which have words beginning with mo.)
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Results = Modern, Module, Mo La La

Note:  Emotions has the letters “mo” in it, but does not begin with “mo”,
so is not found using this query.

In Title and In Number Example
This works the same way except there is an implied asterisk before the search
term.  Searching for mo* will find the same results found by the In Text
search, plus Emotions.

In Number Example
If searching for the document, 290-3407-453, typing 290-3407 or  290-*-453
will find the document, but 290-340* will not.

6.4.2  Question Mark Searches
The question mark serves as a wildcard character representing any single
character.

Example
1. “F?lling” will retrieve “Less Filling” because ? matches a single character.

2. “F?ling” will not match “Less Filling” because ? matches only a single
character, unlike asterisk (*) searches.

6.5  Search Areas
Use the Search Editor to type search terms that combine to form a query.
All In Text searches are combined first, joined by the conjunctions specified
in the search text boxes.

• All search criteria are combined using the conjunctions selected.  The
result of an In Text search is combined using And or Or with the result
of the In Title or In Number search to produce a final result.

• When performing In Number searches, the set of numbers delineated by
hyphens should be entered as a unit.

• When using an asterisk or question mark wildcard character with a partial
number, you can search one segment delineated by a hyphen.

• Clicking Search starts a search based on the search terms (up to four),
their conjunctions (And, Or, or Is Near), and their location (In Text, In
Title, In Number).

• Results display in the browser window.  The list displays the documents
by the document number and document title.  Clicking Sort by allows you
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to sort the documents in either ascending or descending order based upon
the following options:

1. Relevance
2. Revision
3. Title
4. Number
5. Pages
6. Type
7. Function
8. Product

• To print the document list, choose the Print Document List command
from the File menu.

• Click Clear Search to clear the search criteria and display all documents
in the opened collections.  Clear Search does not change Set Categories
selections.  Click Set Categories to change those settings.

6.5.1  Printing a Document List
Select the Print Document List command from the File menu to print a copy
of the contents of the browser window.

Fields listed include: document number and document title

6.5.2  AND Conjunction
The And conjunction is the default.  It finds documents that have both the
first search term and the second search term.

Example
If "line" and "trunk" are the search terms and the conjunction is And, the
search will find documents with occurrences of both terms.

6.5.3  Or Conjunction
The Or conjunction finds a document with either the first search term or the
second search term.

Example
If "line" and "trunk" are the search terms and the conjunction is Or, the
search will find documents with occurrences of either term.

6.5.4  Is Near Conjunction
Use the Is Near conjunction to find documents that contain terms that are
within a reasonable distance of each other.  The distance between words for



Searching 6-6

Helmsman 4.0 • User Guide, Version 1.0

Is Near searches is set up in the Helmsman Preferences dialog box.  Select
the Preferences command from the View menu and click the Search tab.

Note 1:  The Is Near conjunction works only with In Text searches.

Note 2:  The And and Is Near conjunctions have higher precedence than
the Or conjunction.  Normally, searches are processed beginning with
the first term entered and moving downward through the remaining
terms.  However, any And and Is Near conjunctions will always be
processed before Or conjunctions.  Regardless of the conjunction used,
searches start with In Title, followed by In Number, and then In Text.

6.5.5  Clear Search
Click Clear Search to clear the search text boxes and refresh the document
list.  Selections in Set Categories remain. The open collections display
without any search criteria applied with the exception of Set Categories.

6.6  Search Occurrences
To view the number of search occurrences for a specific document:

1. Select a document.

2. Click the Search Occurrences button in the browser window.

3. The Search Occurrences dialog box appears.

4. The occurrences of the search terms listed in the Search Editor are
displayed by page number, and include the number of occurrences.

5. Click the Next Document button to open the document that appears
below the current selection in the list.

6. Click the Previous Document button to open the document that appears
just above the current selection in the list.

7. Click the Goto Page button to open the document to the page number.

8. If another document is selected, the Search Occurrences dialog box is
automatically updated with that document’s search occurrences.

6.6.1  Previous and Next Occurrence
The two arrow buttons in the Search Occurrences dialog box allow quick
selection of the Previous Occurrence and Next Occurrence of a search term
in a document list.
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6.6.2  Highlighting
Highlighting is a very useful tool that marks all occurrences of a specified
search term when viewing a document.

One of the options on the Document Viewer tab of the Helmsman
Preferences dialog box is Open document to.

This option determines if  a document opens to either the first page or the
page where the search term is first located.  All occurrences of the search
term are highlighted.



Index

Helmsman 4.0 • User Guide, Version 1.0

ii

Index

A
Acrobat Exchange, 1-1, 2-1, 5-1
AND Conjunction, 6-5
Asterisk Searches, 6-3

B
Browser window, 1-2, 4-1, 5-1

C
Clear Search, 6-6

button, 6-6
Client/Server, 1-1

collections, 1-1, 4-1, 5-1, 6-3

D
Data Source, 3-1, 3-2
Document List, 6-5
document number, 1-1, 6-5
Document Properties dialog, 5-1
Document Viewer, 3-2
Document Viewer Preferences, 3-2

H
Helmsman Browser Window, 4-1
highlighting, 4-1, 6-3
Highlighting, 6-6, 6-7

I
IS NEAR Conjunction, 6-5

K

key, 6-3

N
network server, 3-1
Next and Previous Document, 5-1
Next Occurrence, 6-6

O
Open button, 4-1
Open Collection, 4-1, 5-1, 6-3
OR Conjunction, 6-5

P
Preferences, 3-1
Printing a Document, 5-1, 6-5

Q
Question Mark Searches, 6-4

R
Retrieving and viewing documents, 5-1

S
Search Areas, 6-4
Search button, 6-6
search editor, 5-1, 6-1, 6-3
search occurrences, 6-5
Search Preferences, 3-2
searching, v, 1-2, 5-1, 6-1
Set Categories, 6-1, 6-3, 6-6
successful search, 5-1, 6-1

T
Technical Support, 2-2
toolbar, 1-1, 5-1

V
View menu, 6-1
viewing documents, 1-2, 5-1

W
Word List, 6-3

Copy, 6-3



Helmsman 4.0 for Macintosh

Helmsman 4.0
User Guide

Address comments to:
NORTEL NETWORKS
200 Athens Way
Nashville, TN  37228-1397

Attention: Manager, Helmsman Data Warehousing

Copyright © 1991-1999 Northern Telecom, All Rights Reserved.

Printed in the United States of America

NORTEL NETWORKS CONFIDENTIAL: The information contained herein is the property of Nortel Networks and is strictly
confidential. Except as expressly authorized in writing by Nortel Networks, the holder shall keep all information contained herein
confidential, shall disclose it only to its employees with a need to know, and shall protect it, in whole or in part, from disclosure and
dissemination to third parties with the same degree of care it uses to protect its own confidential information, but with no less than
reasonable care. Except as expressly authorized in writing by Nortel Networks, the holder is granted no rights to use the information
contained herein.

NORTEL NETWORKS is a trademark of Northern Telecom.
HELMSMAN is a trademark of Northern Telecom.
VERITY is a worldwide trademark of Verity, Inc., registered in the United States and numerous other countries worldwide.
ADOBE, the ADOBE logo, ACROBAT, and the ACROBAT logo are trademarks of Adobe Systems Incorporated.  Portions Copyright
1996 Adobe Systems Incorporated.
All rights reserved.  Other named products are trademarks of their respective companies.

Publication number:  P6406
Product release:  Helmsman 4.0
Document release:  Version 01.02
Date: November 1999
Printed in the United States of America


